latest version latest version follow on Twitter

Helidon Build Tools

Build tools for the Helidon Project.

Helidon Compatibility

The Helidon Build Tools version is aligned with the Helidon major.minor version. I.e Helidon Built Tools version X.Y.? is compatible with Helidon version X.Y.?.

Build

You will need Java 11 and Maven 3.6.3 or newer.

Full build

$ mvn install

Checkstyle

# Cd to the component you want to check
$ mvn validate  -Pcheckstyle

Copyright

# Cd to the component you want to check
$ mvn validate  -Pcopyright

Spotbugs

# Cd to the component you want to check
$ mvn verify  -Pspotbugs