JS GraphQL IntelliJ Plugin

GraphQL language support for WebStorm, IntelliJ IDEA and other IDEs based on the IntelliJ Platform.

Features overview

Documentation

The main documentation site is available at https://jimkyndemeyer.github.io/js-graphql-intellij-plugin/

Which IDEs are compatible with the plugin?

The plugin is compatible with version 2018.2+ (182.711 or later) of all IDEs based on the IntelliJ Platform, including but not limited to WebStorm, IntelliJ IDEA, Android Studio, RubyMine, PhpStorm, and PyCharm.

Where can I get the plugin?

The plugin is published to the JetBrains Plugin Repository.

To install it, open your IDE "Settings", "Plugins", "Marketplace" and search for "GraphQL".

Acknowledgements

This plugin was heavily inspired by GraphiQL from Facebook.

A number of language features such as query and schema validation are powered by graphql-java.

A thanks also goes out to the Apollo and Prisma teams for their continued efforts to improve the GraphQL Developer Experience.

And finally, a thank you to the JetBrains WebStorm team and the Alpha/Beta testers for all their help in getting the 2.0 release across the finish line.

License

MIT